fmwebschool.com
Top Experts [learn more]Top 4-10
webko

9743 K
bandmandq

2458 K
Genx

1525 K
4. tcmeyers
5. kbata
6. Martie
7. Hammerton
8. rrenfrow
9. bneeman
10. plegler
Welcome, Guest. Please login or register.
September 23, 2014, 03:19:46 AM

Login with username, password and session length
Search:     Advanced search
Welcome to the FileMaker Web Masters Exchange.  If you have any questions about how to use this forum, please watch the getting started movie at:
http://www.fmwebschool.com/movies/forum1/forum1.html
27796 Posts in 6150 Topics by 1525 Members
Latest Member: alkyred
* Home Help Search Calendar Login Register
+  fmwebschool.com
|-+  FileMaker Inc Products and Technologies
| |-+  Instant Web Publishing
| | |-+  unblocked 591
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Print
Author Topic: unblocked 591  (Read 2007 times)
jrough
Jr. Member
**
Offline Offline

Posts: 46


« on: October 13, 2009, 11:12:18 AM »

I think I successfully unblocked port 591 on my router and I still can't get to it from outside my local network.  I also have the firewall on the hosting machine turned off.  It seems like it should work.  I'm just getting my apache server not IWP or port 80 or port 591.
Logged
brich
Newbie
*
Offline Offline

Posts: 18


« Reply #1 on: October 19, 2009, 10:34:14 AM »

I'd check two things.

Firstly, using a separate computer on the local side of your network, can you access IWP on your host computer using a web browser? This is just to check that the firewall on the host computer is not getting in the way. 

Once you have this working, you can move onto the router. I'm not familiar with this particular router, but I guess you must be able to set up a DMZ host or some kind of static routing so your router can pass requests for the IWP port to the host?  You say you can reach your Apache server so this suggests that port 80 at least is being routed correctly.  One thing you could try is to stop your Apache server temporarily, reset the Filemaker IWP client to work on the standard port 80, and see if you can reach it from outside. If this works, and the first step works, then you know the issue must be with port routing.

Once you've got this working, please reactivate the firewall on the host computer with just the appropriate ports opened. Having a DMZ host with no firewall is a recipe for disaster for the security of your host server.

This useful blog post from SixFriedRice explains the ports that need to be opened.  http://sixfriedrice.com/wp/filemaker-firewall/ 

Hope this Helps

Brian
Logged
jrough
Jr. Member
**
Offline Offline

Posts: 46


« Reply #2 on: October 20, 2009, 10:04:27 AM »



I found the problem was the router.  With AT&T you have to have DHCP turned on in your mac.  I was cheating.  I had use DHCP with a manual address.  I will try that again but I think this blocked the port forwarding even though it looked right.  It must be on the AT&T side.  However if you use the DHCP setting you can use some software that forwards your IP address with you.  Check out www.no-ip.com for free and purchased software that is cheaper than a dedicated IP address.  I haven't tested it with FM yet.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!