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Rapidly develop FileMaker Websites with FMStudio.  FMStudio enables you 
to connect FileMaker and Dreamweaver.  FMStudio all ows you to work with 
live FileMaker data in the Dreamweaver environment.  
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Welcome  
 
Welcome to the FMStudio Quick Start Guide.  We are extremely excited about FMStudio and 
have many wonderful features we will be adding.  We hope that you find this Quick Start Guide 
very helpful.   
 
If you have suggestions, as to how we can improve this guide and FMStudio, please email us at 
info@fmwebschool.com or join the FMStudio forum at:  http://fmwebschool.com/frm  
 
The FMStudio forum consists of hundreds of FMStudio users ready to help with any questions 
you might have.  The forum is made up of a wonderful community of developers encompassing 
many different levels of expertise.  FMWebschool employees also monitor the forums 7 days a 
week.   
 
FMWebschool has also created a Wiki that contains tutorials, updates and bug fixes.  The Wiki is 
located at:  http://www.fmwebschool.com/reference/Main_Page  
 
 
 
Introduction  
 
FMStudio is a FileMaker Server Model for Dreamweaver.  Currently, FMStudio works with 
Dreamweaver MX, MX 2004, Dreamweaver 8 and Dreamweaver CS3.  FMStudio works equally 
well on both Mac and Windows. 
 
FMStudio is amazingly powerful!  FMStudio enables individuals that have never worked with 
custom web publishing to create dynamic FileMaker web solutions for clients and prospective 
clients.   
 
If you are a business owner, you can now use FileMaker for internal business solutions as well as 
quickly build a database powered web solution for your own business or for your contacts.  I 
encourage you to watch the movies on our FMWebschool website to see what’s possible. 
 
Simply put, FMStudio enables you to see and work with live FileMaker data inside Dreamweaver.  
This enables you to create a site or a table inside Dreamweaver, and then quickly drag and drop 
FileMaker fields into the Dreamweaver table. 
 
FMStudio will enable FileMaker beginners and professionals the ability to increase productivity 
and add time and value to their lives. 
 
We hope that you enjoy FMStudio! 
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Software Requirements  
 
If you will be hosting your own FileMaker solution,  you will need the following: 
 
Windows 
 
Filemaker Server Advanced 7 – 8 or FileMaker Server 9 for FX.php 
FileMaker Server 9 for PHP API 
Windows XP Pro with IIS installed, or Windows Server 2000 with IIS installed, or Windows 2003 
with IIS installed. 
Dreamweaver MX, MX 2004, Dreamweaver 8 or Dreamweaver CS3 
PHP and cURL installed and configured 
FMStudio Extension Installed 
 
Macintosh 
 
Filemaker Server Advanced 7 – 8 or FileMaker Server 9 for FX.php 
FileMaker Server 9 for PHP API 
Macintosh OS X 10.3.1, 10.4.1+ with Apache Server Installed and configured and Personal Web 
Sharing turned on. 
Dreamweaver MX, MX 2004, Dreamweaver 8 or Dreamweaver CS3 
PHP and cURL installed and configured 
FMStudio Extension Installed 
 
If you have a FileMaker hosting company hosting you r files, you will need the following: 
 
Dreamweaver MX, MX 2004, Dreamweaver 8 or Dreamweaver CS3 with the FMStudio Extension 
installed.  We recommend http://www.fmgateway.com for hosting. 
 
 
Quick Note  
 
If you have Firewall software running, this may int erfere with your Server connection, 
causing FMStudio to not work correctly.  We have fo und Zone Alarm to be especially 
problematic.  Please shut down Zone Alarm when sett ing up, and working with FMStudio. 
 

 
Image 1.  Firewall Software 
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Initial FileMaker Set-up  
 
To begin FileMaker web publishing, you need to make sure that you have your FileMaker 
database configured correctly.  This is true for both local and remote databases.  To configure 
your database, you will need to set up the correct access privileges. 
 
Let’s make sure your access privileges are set up properly. 
 
First, open FileMaker and choose File > Define > Accounts & Privileges  as shown below.  
 

 
Image 2.  Menu for Accounts and Privileges  
 
This will open the Define Accounts and Privileges Window 
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Image 3.  Define Accounts and Privileges Window 

 
I have already created an account named “webuser ” with “Data Entry Only” privilege rights 
assigned.  You will need to create an account for web access.  To do this, click on the “New” 
button. 
 
The “Edit Account” window will open.  Enter an account name and password and choose an 
appropriate privilege set. 
 
Once you have finished filling in the needed information, you can press "OK".  To modify the 
Privilege Set, you can simply press the “Edit” button for other options. 
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Image 4.  Edit Account Window 
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Extended Privileges 
 
The Define Accounts and Privileges window has three tabs.  In order to use PHP with FileMaker 
you will need to add two additional permissions.   
 
“fmxml ” for FX.php  &  “fmphp ” for the FileMaker API for PHP 
 
These new permissions are shown in the example below.   
 

 
Image 5.  Extended Privileges Set up  
 
Setting Up Extended Privileges 
 

 
Image 6.  Extended Privileges Window set up for fmx ml 
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First, click on the “New” button.  The Edit Extended Privileges window will open.   
In the Keyword field, type “fmxml” without the quotes.  This will allow you to use FX.php with your 
solution. 
 
Select the same Privilege Set that you previously selected for your web access account, and then 
click "OK". 
 
Next, let’s go ahead and set up FileMaker to work with the New FileMaker API for PHP. 
 
 

 
Image 7.  Extended Privileges Window set up for fmp hp  
 
 
 
First, click on the “New” button.  The Edit Extended Privileges window will open.   
In the Keyword field, type “fmphp” without the quotes.  This will allow you to use the FileMaker 
API for PHP with your FileMaker Solution. 
 
Select the same Privilege Set that you previously selected for your web access account, and then 
click "OK". 
 
You have just configured FileMaker to work with FX.php and the new FileMaker API for PHP.  
Your database is now ready to be hosted locally on your FileMaker Server Advanced Server / 
FileMaker Server 9, or at a FileMaker Hosting company. 
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Installing the FMStudio Dreamweaver MXP extension  
 
When you download and unzip the FMStudio Extension, you will notice that it looks something 
like this. 
 

 
Image 7.  FMStudio Dreamweaver Extension Package  
 
FMStudio is a special extension written for Dreamweaver that enables FileMaker to communicate 
with Dreamweaver.  FMStudio is a FileMaker Server Model for Dreamweaver. 
 
There are numerous ways to install Dreamweaver extensions.  I am going to go through the step-
by-step process using the Dreamweaver extension manager.   
 
 
 
 
First Time Installing FMStudio  
 
 
*Note:  There are several FMStudio Dreamweaver Exte nsion Packages.  Dreamweaver MX 
and Dreamweaver MX 2004 will only allow you to inst all and use one FMStudio Extension 
at a time.   
 
Do not ever disable one FMStudio extension to insta ll the other one, you must completely 
uninstall it first. 
 
This means you would have to decide whether you wan ted to work with FX.php or the 
FileMaker API for PHP. 
 
Dreamweaver 8 / Dreamweaver CS3 does not have this limitation, and allows you to install 
and use both FX.php and the FileMaker API for PHP s imultaneously.  
 
You should NOT have both MX and DW8 versions of pac kages installed for a single 
version of Dreamweaver, please select the appropria te packages for your version of 
Dreamweaver. Packages with "dw8" in the name are fo r Dreamweaver 8 / CS3 version only, 
while packages with "mx" are for Dreamweaver MX and  Dreamweaver MX2004. 
 
If this is your first time installing FMStudio, the process could not be easier.   
 
Whether your are using a Windows version or Macintosh version of Dreamweaver, you will be 
able to locate the Extension Manager under the Dreamweaver help menu as shown below. 
   
Simply open Dreamweaver and select Help > Manage Extensions 
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Image 8.  Menu to Manage Dreamweaver Extensions 
 

 
 
The Dreamweaver Extension Manager will open as shown below. 
 

 
Image 9.  Dreamweaver Extension Manager  
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Click the Install button. 
 
You will have to navigate to the file on your desktop.  Then install the extension.  Dreamweaver 
will do the rest!  Once the extension has been installed, close Dreamweaver and restart 
Dreamweaver.  That’s it! 
 
 
Installing an FMStudio Update  
 
If you have previously installed the FMStudio extension, you will need to delete the extension and 
install the new extension package.  This is extremely easy to do.  Once again, open 
Dreamweaver, and select: Help > Manage Extensions 
 
The Dreamweaver Extension Manger will open as shown in Image 10 below.  Simply select the 
old Extension Package, and select the trashcan to delete the extension.  You must delete the old 
extension, do not disable it. 
 
Next, just as if we were installing the package for the first time, click on the “install’ button.  
Navigate to the location of the new FMStudio extension package, and install it.  Close and restart 
Dreamweaver.  Congratulations you have just installed FMStudio. 
 
 

 
Image 10.  Dreamweaver Extension Manager (Delete Ex tension) 
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Creating a New Site  
 
In this next section we will discuss creating a new website.  We will use Dreamweaver to create 
the site. 
 
Open Dreamweaver, and select Site > New Site  
 

 
Image 11.  Create a new web site 
 
 
The Site Definition window will open as shown on the next page.   
 
For Site Name , enter your website name.  In the example below, I am using “quick_start” 
 
The next box is the Local Root Folder.  This is usually the root level of your web server.  For 
Windows this would be: 
 
C:\intetpub\wwwroot 
 
For Macintosh, this would be: 
 
Hard Drive/Library/Web Server/Documents 
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Image 12.  Site Definition for “quick_start” websit e. 

 
Next, select the file folder beside the ‘Local root folder” text box.  This will allow you to navigate to 
the root level of your web server.  This is where you will create your new website folder as shown 
in the image below. 
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Image 13.  Choose local root folder, create your ne w website folder and then select it. 
 

 
Navigate to the root level of your webserver.  Select the “create a new folder” icon and name the 
new folder.  Select that folder, press the “select” button, and click “OK”.  The path to the website 
will now be added to the “Local root folder” text box as shown in the image on the next page. 
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Image 14.  Add your local address to the HTTP Addre ss field.  
 
Next, add your local address, which is usually 127.0.0.1 to the HTTP address field.  Once this has 
been accomplished, select “Remote Info” from the Category box located in the upper left corner 
of the Site Definition window. 
 
 
 
 
Setting Up Remote Info 
 
Next we will need to set up “Remote Info”.  You can set up a website locally or remotely using the 
FTP option.  In this Quick Start Guide, we will cover Local set-up and FTP set-up.  If you have 
your database hosted on a remote server or you are using a hosting company like 
http://www.fmgateway.com then please follow the instructions by selecting the link below- 
http://fmwebschool.com/reference/Setting_Up_FMStudio_with_FMGateway  
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Local Setup 
 
Select “Remote Info” from the Category window. 
 
From the “Access” dropdown box, select “Local/Network” as displayed below. 
 
If the correct directory is not showing up in the “Remote Folder” text box, simply click on the folder 
beside the text field, and navigate to the proper folder.  The other options can remain in their 
default settings. 
 
 
 

 
Image 15.  Set-up Remote Information. 
 
We are almost finished setting up the new site.  Now we simply have to set up the testing server. 
 
 
Setting up the Testing Server 
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Choose “Testing Server” from the Category window. 
 
From the “Server Model” drop down list, select either PHP FileMaker if you are using the new 
FileMaker API for PHP or PHP FileMaker FX if you are using FX.php as shown below. 

 
Image 16.  Set up Testing Server. 

 
Select Local/Network from the “Access” drop down list.  
 
Next, make sure the correct path to your website folder is listed in the text box labeled “Testing 
Server Folder”.  If not, click on the file folder beside the text field, and navigate to the correct 
folder and select that folder. 
 
Lastly, the URL prefix should contain the location of the site’s root folder on the testing sever.  In 
this example it is http://127.0.0.1/quick_start/. I could also have http://localhost/quick_start/. 
 
If your website is hosted by a FileMaker hosting provider, you will need to use the full address 
that they give you to connect to the database.  You will need to enter this address in the “URL 
Prefix” text box field, including any subfolders if this site is placed into a subfolder of your 
document root. 
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Image 17.  Add the URL Prefix for either local or r emote server. 
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Using FTP with FMStudio 
 
To use a remote PHP server with FMStudio, you will need to setup an FTP connection to the 
server inside of Dreamweaver. To do so, go into the remote server tab and select the "FTP" 
option. Enter your FTP details in the dialog, making sure to enter the correct subfolder path, 
relative to the first directory that FTP logs you into. Make sure that the subfolder on your FTP site 
has read and write permissions for all users to avoid permission related problems with the PHP 
files. 
 

  
Image 17B.  Setting UP FTP Access.  
 
It is also very important to push the API files to the remote server if you are using FTP. To do so, 
make sure the Dreamweaver Files tab is selected.  Next highlight the FileMaker folder and 
FileMaker.php file for PHP API users, or highlight the FX folder for FX.php users as shown in the 
screen shot below.    
 
** Any new installations or updates to your connect ion files, API files and FMStudio 
modules will need their generated files pushed to t he FTP server. ** 
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Image 17C.  Select the FileMaker folder and the Fil eMaker.php file.  
 
 
Once the correct API files are highlighted, right click on them and use the put option to upload the 
files. If the put option is not available, you might be in the remote file view, and should switch to 
the local file view.  
 

 
Image 17D.  Right Click, or Control Click and Select “Put” from the menu.
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If you already have a website 
 
If you already have a web site and would like to use FMStudio with the site, you must convert 
each plain PHP file to an FMStudio compatible file.  To do this, inside Dreamweaver, navigate to 
the Commands Menu and choose the "Convert File to FMStudio" option. 
 

 
 
Image 18.  Select Convert file to FMStudio to conve rt a plain PHP page to an FMStudio page.  
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Creating a Dynamic PHP Page for Testing  
 
Before you attempt to install FX.php or the new FileMaker API for PHP with FMStudio, we will 
need to create a dynamic PHP page to let Dreamweaver know that we will be working with a 
FileMaker PHP protocol.  Dreamweaver MX and MX2004 will not have the PHP for  FileMaker 
dynamic page types; simply select PHP and it will w ork.  You can confirm that this worked 
by finding an FMStudio related comment within the c ode view.  
 
To create a new page, either click the “More” folder as shown below, or click File > New  from the 
main menu.   
 
 
 

 
Image 19.  Select the “More” folder to create a new  dynamic page.  
 
This will open the new document window as shown below.     
 
From the Category Window, select “Dynamic Page”. 
 
The Dynamic Page window will be populated with a list of options.  If you will be working with the 
FileMaker API for PHP, select “PHP for FileMaker”.  If you will be working with FX.php, please 
select “PHP for FileMaker FX”. 
 
Once you have made your selection, select the “Create” button.  This will create a new web page 
for you. 
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Image 20.  Select Dynamic Page from the Category li st.  
 
You will see that an “untitled page” has been created.  Simply name and save the web page to 
your site folder.  Dreamweaver is now ready to install either FX.php or the new FileMaker API for 
PHP. 
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Installing the FileMaker API for PHP and FX.php  
 
Installing FX.php and the FileMaker API for PHP with FMStudio could not be easier.  
 
To install the FileMaker API for PHP 
 
From the main menu, select: Commands > Install FileMaker PHP API 
 
To install FX.php 
 
From the main menu, select: Commands > Install FX.php  
 
 

 
Image 21.  Select Commands and then Install FileMak er PHP API or Install FX PHP. 

 
A dialogue box will ask if this is the correct directory, click OK if the directory path is correct. 
 

 
Image 22.  Make sure PHP is being installed to the correct directory. 
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Installation can take 10-15 seconds.  Once the installation is complete, the FX.php / FileMaker 
API for PHP files will appear in your web folder under the “Files” tab as shown below. 

 
Image 23.  Installed files showing up under the Fil es tab. 
 
If you are using FTP, right click the FileMaker folder right now, and choose "put" to push it to the 
server, then do the same to the FileMaker.php file. 
 
In the next section, we will cover setting up a database connection with Dreamweaver.  This will 
enable us to connect FileMaker to Dreamweaver. 
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Setting Up a Database Connection  
 
In order to work with Dreamweaver and FileMaker, we need to make sure that they can 
communicate.   
 
The connection options are located under the “Application” panel and the “Databases” tab. 
 

 
Image 24.  Set up the database connection. 

 
Simply click the “+” button.  You will see a small drop down that says “FileMaker Connection”.  
Click on this option.  (There are other connections that are covered in our Quick Start video 
series) 
 

 
 
Image 25.  Select the FileMaker Connection pop-up.  
 
The FileMaker Connection window will open.  Follow these steps to fill in the proper criterion. 
 
Connection Name:  This can be any name; I am using “QuickStart” in this example 
 
Since my server is being hosted locally I will use 127.0.0.1.  If you were using an external server 
you would need to include the entire address to the server.  Your FileMaker hosting company 
should provide you with this address. 
 
User Name and Password:  This is the web user name and password that we set up in the 
FileMaker Accounts section at the beginning of this guide. 
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Once you have completed these options, click on the “select” button. 
 

 
Image 26.  Enter the required details in the FileMa ker Connection window. 

 
Once you have chosen the “select” button, the “Select Database” window will appear with a list of 
all databases available.  Simply select the database you wish to use, and then click OK. 
 

 
Image 27.  Select the appropriate database from the  dropdown list. 
 
 
 

 
Image 28.  Click the “Test” button to test your Fil eMaker Server Connection.  
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You can also test your connection by selecting the “Test” button.   
 

 
Image 29.  Connection Successful Display, Press OK to continue. 

 
Once the database has been set up, you will be able to see all of the Layouts, Scripts, Value Lists 
and Portals.  If you cannot list all of your layouts and see fields from at least one layout, then your 
connection settings are likely incorrect and might have to do with user permissions in the 
database.  Be sure to make sure they are set up correctly. 
 

 
Image 30.  Your database data will display under th e Databases tab  
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Resources  
 
 
Quick Start Video Series 
 
Once again, please be sure to check out our movie section!  We add new movies quite often.  
You can check out the FMStudio User Videos at: 
http://www.fmwebschool.com/fmstudio_user_videos.php 
 
FMStudio Webinars 
 

 
 
FMWebschool offers free webinars every month.  To view a list of current and upcoming 
webinars, navigate to:  http://www.fmwebschool.com/fmstudio.php  
 
FMStudio Web Hosting Options 
 

  
 
If you do not have a copy of FileMaker Server Advanced or FileMaker Server 9, there is no need 
to worry.  FMGateway hosting will host your database files for you!  http://www.fmgateway.com 
FMGateway will help you set up your database and configure Dreamweaver to communicate with 
your hosted database.  FMGateway' s Wiki gives a step-by-step process describing how to set up 
your website.  http://fmwebschool.com/reference/Setting_Up_FMStudio_with_FMGateway  If you 
want to get started with FileMaker hosting, check out FMGateway. 
 
Updates and Other Resources 
 
FMWebschool has a very busy FMStudio and FileMaker web publishing forum with nearly 
500,000 page hits a month.  Be sure to check out the forum at http://www.fmwebschool.com/frm 
also, visit our FMStudio Wiki to get the latest updates on FMStudio releases at 
http://www.fmwebschool.com/reference  
 
Promote and Market Your Website and Services 
 
Want to learn how to market and promote your services and website?  Check out the FileMaker 
consultant blog at: http://www.fmwebschool.com/filemaker_consultant.htm  
 
 
Watch for our new FMStudio book to be released in February 2008! 
 
 
 
 
FMStudio is Copyright 2008 FMWebschool Inc.  http://www.fmwebschool.com/fmstudio.php  


